[Dev] Chromebook C201 wifi

Josh Branning lovell.joshyyy at gmail.com
Mon Apr 1 15:51:47 GMT 2019

Hi just had a look and there doesn't appear to be an easy option, though 
there are a few things that could help in u-boot by the looks of things, 
I'm not too familiar with u-boot, and it would require probably require 
someone who would know what they were doing to really help.

But I guess probably you'd need to compile u-boot, changing some stuff, 
like grepping for "uA", "uV", "max-current" , "max-current" etc. have a 
look at arch/arm/dts and see what's going in there etc. Probably there 
is a main voltage regulator and a usb voltage regulator, someone who 
knows about electronics could tell you if it could be a problem with 
either, or just one or the other.

You could try typing "power info" from the prompt or something similar, 
which may or may not show you usb current. Else, like you or someone 
suggested, obtain a usb current and voltage meter and work out if that's 
the issue for sure.

U-boot seems to be very board-specific which generally provides some 
evidence against my original hypothesis, though it's difficult to tell. 
Bare in mind, it could be a coincidence that both our arm devices are 
struggling with USB and turn out not be power related at all, cheers,


On 31/03/19 21:24, Josh Branning wrote:
> This is interesting, a while back I tried plugging in an external HDD to 
> an olinuxino (ARM) using parabola, and it didn't get enough power 
> either. At that point, I assumed it was because the board wasn't 
> providing the right power through the USB. I was using a power pack that 
> matched the recommended input voltage and current of the board.
> Possibly a different thing entirely, but you never know ... there could 
> be some setting in the kernel or bootloader or something that means the 
> devices are only getting limited power through the USBs.
> Another way to test if it is a parabola issue, could be to burn a live 
> CD or make a usb of a different distro, and see if the adapter works 
> with that, though if it is solely a bootloader issue, I guess that 
> wouldn't be much help less a alternate one is also supplied. It is 
> something I didn't do, because I assumed it would have probably been the 
> hardware simply being not able to supply required the power.
> Note that on some other less-free similar dev boards, USB hdds worked, 
> albeit with a different distro. I know fosho that on some of these 
> boards there is a bootloader setting where you can adjust the output 
> current/voltage, so there may be one in u-boot too.
> Cheers,
> Josh
> On 31/03/19 20:43, Lee Strobel wrote:
>> lsusb for the Senao EUB9801 says its max power is 450mA, so only 50mA
>> less than the Atheros. However, I suspect those are just numbers
>> someone's typed in a text file somewhere. They might not actually be
>> drawing those currents.
>> It looks like a USB tester can be purchased online for $10. For that
>> money, I might just buy one and actually measure the current draw.
>> Btw, from what I saw on Wikipedia, it looks like a standard usb 2.0
>> port should be able to supply 500mA as standard.
>> Lee
>> On Sun, 2019-03-31 at 14:04 -0400, Lee Strobel wrote:
>>> Hi Denis,
>>>> For the record, the WiFi related bugreport is here:
>>>> https://labs.parabola.nu/issues/2261
>>>> Could you try to see if a USB HUB that is powered by its own power
>>>> supply makes it usable. If you don't have one you may know people
>>>> that
>>>> have one and borrow it just for doing a quick test.
>>> I will see what I can do. I can't think of anyone I know off-hand who
>>> would have an externally-powered USB hub, but I will ask around.
>>> About the power thing: I actually have an older USB wifi dongle, a
>>> 'Senao EUB9801', which seems to work great when plugged directly into
>>> the Chromebook (if I use the firmware blob). According to the kernel
>>> boot log, I think it is running on a Ralink chip of some kind. I will
>>> try to investigate, as you suggested, and see if it requires less
>>> power
>>> than the ThinkPenguin dongle. It is older (~8-10 years), so maybe it
>>> is
>>> using an older wifi technology that consumes less power?
>>> The reason I asked about the kernel devs is just because I was
>>> wondering if the team that maintains the module for the Atheros chip
>>> are aware of the issue. I would think we might need their assistance,
>>> if any of us wanted to try to modify the module.
>>> Lee
>>> _______________________________________________
>>> Dev mailing list
>>> Dev at lists.parabola.nu
>>> https://lists.parabola.nu/mailman/listinfo/dev
>> _______________________________________________
>> Dev mailing list
>> Dev at lists.parabola.nu
>> https://lists.parabola.nu/mailman/listinfo/dev

More information about the Dev mailing list