[Dev] Massive package breakage on i686 (missing libraries)

Denis 'GNUtoo' Carikli GNUtoo at cyberdimension.org
Tue Nov 6 18:38:33 GMT 2018

On Tue, 30 Oct 2018 12:08:43 -0300
Freemor <freemor at freemor.ca> wrote:

> Some thing in this list strike me as odd 
Given the size of the list, I expected it to have some false positive
when I sent the first email, and there indeed were some.

== iceweasel and icedove ==
> for example on my i686 machine currently fully -Suy'd 
> Iceweasel works fine

Here I can also launch iceweasel fine, and I still have the same
version of iceweasel installed:
> libre/iceweasel 1:61.0.2-1.parabola3 [installed]
>     Libre standalone web browser based on Mozilla Firefox

Here's what was on the log I sent before:
> iceweasel (1:61.0.2-1.parabola3):
> /usr/lib/iceweasel/plugin-container: libxul.so
> /usr/lib/iceweasel/libmozavcodec.so: libmozavutil.so
> /usr/lib/iceweasel/libxul.so: libmozsandbox.so liblgpllibs.so
>                               libmozgtk.so

If I look at theses individual libraries some are broken:
> $ ldd /usr/lib/iceweasel/libmozavcodec.so
> 	linux-gate.so.1 (0xb7fa2000)
> 	libpthread.so.0 => /usr/lib/libpthread.so.0 (0xb7ec6000)
> 	libmozavutil.so => not found
> 	libc.so.6 => /usr/lib/libc.so.6 (0xb7ce4000)
> 	/usr/lib/ld-linux.so.2 (0xb7fa4000)

So maybe it does not uses theses libraries(plugin-container,
libmozavcodec.so, libxul.so), or maybe it dlopens them and fails?

I've looked at the x86_64 iceweasel, and there is exactly the same
broken libraries.

Maybe theses are not an issue? or maybe it only affects obscure uses

All the above apply also to icedove.

== gthumb ==
I've also still the same version than the one in the log:
> extra/gthumb 3.6.1-2.0 [installed]
>     Image browser and viewer for the GNOME Desktop

If I look at the log, theses are most probably extensions, so they
may be dlopened or something like that.

> gthumb (3.6.1-2.0):
> 	/usr/lib/gthumb/extensions/libburn_disc.so: libidn.so.11
I launched gthumb, and this extension was deactivated
(Preferences->Extension->Burn CD/DVD). 

When I activated it my screen was flooded with the same error message
appearing. I had to go on real console (ctrl-alt-f2) and kill gthumb.
It should be easy to try: I didn't get increased CPU or RAM usage
while it was happening.

> 	/usr/lib/gthumb/extensions/libraw_files.so: libraw.so.19
I had the same behavior with the Preferences->Extension->RAW format
support, I wrote down the message:
> Could not open the module "raw_files": libraw.so.19: cannot open
> shared object file: No such file or directory

So in this case it's pretty clear that there are still issues even if
it seem to work at first sight.

I don't know why theses extensions were deactivated though.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 833 bytes
Desc: OpenPGP digital signature
URL: <https://lists.parabola.nu/pipermail/dev/attachments/20181106/799e3c4a/attachment.sig>

More information about the Dev mailing list