[Dev] outdated 'nonprism' gnome-settings-daemon

Isaac David isacdaavid at isacdaavid.info
Thu Jun 22 22:34:15 GMT 2017

Robert Alessi :
> Since this update, things are getting better on my laptop too: gnome
> seemingly starts, but ends up with a blank screen. Nothing is frozen
> though for gvim which is set to pop up my reminders shows up as
> expected—but with no decorations.  Guake also works, but that's 
> about
> it.

so you could get past gdm, right?

i tried to reproduce with a full dive into [nonprism] (`pacman -Syyuu
your-privacy`) instead of just replacing the 2 packages, but in my
case i was greeted with a borked gdm which didn't show anything apart
from the pointer.

> I tried the standard version of gnome-settings-daemon which is in
> extra/ and I can tell that everything works with it.

which pulled geoclue2 as dep, right? i don't know how similar our
experiences are, but this bit right here would also make sense to
mine. i'll explain...

>>  some other gnome packages in [nonprism] (e.g. empathy,
>>  evolution-data-server, gnome-weather, grilo-plugins) require need 
>> some
>>  attention.
> But they do not cause this issue in conjunction with
> gnome-settings-daemon, do they?

apparently not. i uninstalled them in full, one by one, and at no
point did gdm work. doesn't imply they aren't required in updated
form, but here comes the interesting part: i put 'em back, then i
restored the stuff that your-privacy originally conflicted with, one
at a time. _i could recover gnome when geoclue2 was present_, no need
for extra/gnome-settings-daemon.

could you try this combination? this would mean there's another
dependency on geoclue2 we must get rid of, somewhere.

Isaac David
GPG: 38D33EF29A7691134357648733466E12EC7BA943

More information about the Dev mailing list