[Dev] outdated 'nonprism' gnome-settings-daemon

Robert Alessi alessi at robertalessi.net
Thu Jun 22 23:39:25 GMT 2017

On Thu, Jun 22, 2017 at 05:34:15PM -0500, Isaac David wrote:
> Robert Alessi :
> > Since this update, things are getting better on my laptop too: gnome
> > seemingly starts, but ends up with a blank screen. Nothing is frozen
> > though for gvim which is set to pop up my reminders shows up as
> > expected—but with no decorations.  Guake also works, but that's about
> > it.
> so you could get past gdm, right?
> i tried to reproduce with a full dive into [nonprism] (`pacman -Syyuu
> your-privacy`) instead of just replacing the 2 packages, but in my
> case i was greeted with a borked gdm which didn't show anything apart
> from the pointer.

Sorry, I wasn't specific enough on that point: no, gdm stopped
working in my case too, so I had to switch to lightdm for gdm just
showed the pointer. Same as you.

> > I tried the standard version of gnome-settings-daemon which is in
> > extra/ and I can tell that everything works with it.
> which pulled geoclue2 as dep, right? i don't know how similar our
> experiences are, but this bit right here would also make sense to
> mine. i'll explain...

quite right: more below...

> > >  some other gnome packages in [nonprism] (e.g. empathy,
> > >  evolution-data-server, gnome-weather, grilo-plugins) require need
> > > some
> > >  attention.
> > 
> > But they do not cause this issue in conjunction with
> > gnome-settings-daemon, do they?
> apparently not. i uninstalled them in full, one by one, and at no
> point did gdm work. doesn't imply they aren't required in updated
> form, but here comes the interesting part: i put 'em back, then i
> restored the stuff that your-privacy originally conflicted with, one
> at a time. _i could recover gnome when geoclue2 was present_, no need
> for extra/gnome-settings-daemon.
> could you try this combination? this would mean there's another
> dependency on geoclue2 we must get rid of, somewhere.

For the time being, here's what I did:
- keeping nonprism/gnome-settings-daemon, "pacman -Syu geoclue2",
  which just took out 'your-privacy' without touching any of the
  already installed nonprism packages. Et voila, everything worked
  perfectly, gdm included!
- then reverted to the previous state with "pacman -Syu your-privacy",
  which of course took out geoclue2, and broke either gdm and gnome.

This little expermiment leads me to the conclusion that, as you said,
the latest nonprism/gnome-settings-daemon is fine. There must be
some other culprit lying somewhere in need to be nonprismed.

What do you think?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.parabola.nu/pipermail/dev/attachments/20170623/64f9b58e/attachment.sig>

More information about the Dev mailing list