[Dev] Problems with linux-libre-4.6.3_gnu-1 and 4.6.4_gnu-1 x86_64

nospam at curso.re nospam at curso.re
Fri Jul 22 21:04:42 GMT 2016

Luke <g4jc at openmailbox.org> writes:

> On 07/20/2016 05:15 PM, nospam at curso.re wrote:
>> Hi all,
>> I hope that this is the correct mailing list for my question (posting
>> from GMane, this is the only "parabola" list I found).
>> I have been an happy Parabola GNU/Linux user for a while, but I've
>> recently hit a strange problem with the latest kernel packages, namely
>> the 4.6.3 and 4.6.4 for x86_64 architectures.
>> The problem is that when I upgrade to 4.6.3 the systems cannot boot and
>> falls back in maintenance mode complaining about plymouth. I have not
>> investigated this further and waited patiently for the next upgrade.
>> With 4.6.4 the system somehow boots, but it cannot load a number of
>> modules. Upon further inspection I noticed that `uname -r` would give me
>> the older kernel version (i.e. 4.6.2) rather then the latest. So I guess
>> that then the kernel was looking for its modules in the wrong place
>> (i.e. in the 4.6.2 directory that did not exist any more after the
>> package upgrade). I wonder what might have gone wrong because neither
>> the package upgrade with `pacman` nor `mkinitcpio -p linux-libre` seemed
>> to give error messages. Yet, I ended up with the "wrong" kernel.
>> Do you have any advice to help me fix this?
>> Many thanks,
>> -- Stefano
>> _______________________________________________
>> Dev mailing list
>> Dev at lists.parabola.nu
>> https://lists.parabola.nu/mailman/listinfo/dev
> Hello Stefano,
> Was this a fresh install of Parabola GNU/Linux-libre or did you migrate
> from Manjaro/Arch? The reason why I ask is I had a similar issue at one
> point on a migrated system, it would actually boot from the older kernel
> sometimes.
> I would start by checking the /boot directory to ensure that the
> linux-libre kernel is properly installed, followed by checking the
> grub.cfg to see if it is in fact booting the latest kernel. It should
> not be booting the old kernel once a new kernel is installed, so uname
> shouldn't mention the old version either.

Luke, you gave me a great hint!

I have recently migrated hard disk and copied my data over. For some
reason I think I forgot to update fstab with the new boot partition, so
the partition was *not* mounted when I ran pacman -S linux-libre. I was
so sure that there was nothing wrong with /boot that had not even
thought to look at it!

In fact, the package upgrade worked well, but the image was saved in the
/boot folder in the *wrong* partition and wasn't picked up at boot.

I have now fixed by fstab and all works well again.

Thank you very much for taking the time to answer my query.


-- Stefano

More information about the Dev mailing list