[Assist] IceCat: SIGSEGV in safe mode: How to debug?

Rudolf Dovičín rudolf.dovicin at gmail.com
Wed Oct 3 11:33:57 GMT 2018

2018-10-02T21:30:11-03:00 Freemor <freemor at freemor.ca> wrote:
> You'd want to run something like:
> wget -r -np -nd https://git.parabola.nu/abslibre.git/tree/libre/icecat/
> inside the directory toy downloaded the PKGBUILD to.

Thank you very much for your reply & help. :-)

> you could try strace to see what is causing the issue.

I would try, but I have to learn how to filter it, it is very verbose
by default...

> Can you say more about the error.
> Why are you trying to run in safe mode?

Because it crased in standard (non safe) mode.

> What architecture?

(On my ThinkPad X200 with Intel P8600 and LibreBoot. It has some issue
during booting - sometimes it stops with strange horizontal lines on
screen, but after rebooting everything runs smoothly. (Due this I do
not turn off it frequently.) I think it is not related to errors in
browsers, because I use this computer for more than whole year and it
has no problems earlier and currently no problems with another

> What are you doing when it crashes?

I tried to open some pages like

> When did this start? etc?

When I tried to turn off some add-ons.
But I cannot reproduce it, now.
Now it behaves wrongly, too.
It very often writes error:
Gah. Your tab just crashed.
We can help you!

Choose Restore This Tab to reload page content.

With this crash, it writes to terminal this messages:
[Parent 2605] WARNING: pipe error (54): Connection reset by peer: file
line 322
[Parent 2605] WARNING: pipe error (46): Connection reset by peer: file
line 322
[Parent 2605] WARNING: pipe error (43): Connection reset by peer: file
line 322

###!!! [Parent][MessageChannel] Error:
(msgtype=0x2C0085,name=PBrowser::Msg_Destroy) Channel error: cannot

It wrote this even before segmantation fault crash.
I do not remember, when did it (crashing of tabs only) start, but it
was some weeks ago.

During this mornig/night I have run Extended Test by GSmartControl on
my disk (Samsung SSD 850 PRO 512GB), It finished without errors.
SMART Attributes are all correct, too.

( I try to use all big browsers like Iceweasel, IceCat, Epiphany and
QupZilla (except Eolie, because it seems to be not supported by
profile-sync-daemon), too, because every browser has some issue on my
Iceweasel behaves strange on Facebook: When I paste something there,
text area in HTML form dissapears.
And there is problem with history Iceweasel and QupZilla: They do not
remember settings, history, cookies. I think it is issue of
profile-sync-daemon. Epiphany does not play HTML5 videos, which IceCat
But they are issues for another threads, I think. :-)
Rudolf Dovičín
Matice slovenskej 1260/4-7
957 04  Bánovce nad Bebravou 4
mailto:Rudolf.Dovicin at Gmail.com
(cellular: +421 940 872 846, short messages only)

More information about the Assist mailing list