[Dev] Issue 1838, OpenRC Install Media

Carl R. Powers powers at copper.net
Wed Jul 11 18:51:27 GMT 2018

On 06/13/2018 08:18 PM, bill-auger wrote:
> this message contains not text but only an HTML part
> please re-send this message as raw text-only
Updated.  Hope this looks better.


Using OpenRC install media (several releases), they used to work,
but no longer.

User creation fails - passwd & group files installed by base are incomplete
(no users, lp, adm, etc).  Solved by copying passwd & group files from the
install media after installing base.  This is I think the problem in Issue

Installation of optional pkgs (lxde, etc) fails without installing 
Able to stop screen scroll during failure.  Errors on "ath9k_htc-firmware"
(only firmware package in list) not in target.  This package was recently
replaced by a different named package in other distros but the target list
has not been updated.  Solved by copying the installation scripts file,
editing it to extract the package installation section and delete the
missing package, then executing this new  pachage.sh script.  This was done
before exiting the main install script by using chroot, or after rebooting
if networking is working.  With these fixes, installation looks

I now have one usable OpenRc installation to a usb stick after many 
failed attempts.  Will continue but hope to find updated
install media sometime.

As a side note - I tried the systemd lxde versions but they all fail 
with error message "sudoers directory not writeable" and
unable to start networking on the openrc cli  version.

Thanks for making these OpenRc versions available.  Lots of work, I know.

Carl Powers

Update:  I was elated to find the updated OpenRC LXDE install images after
posting the above.  They semm to have fixed my user creation problem but not
the installation of live image packages.  Tried both the from disc and from
network modes with same results.  I was unable to modify the package
script so again, resorted to manually installing all of the packages on the
list.  Seems to work after fighting cups & hostname problems. Still trying
to make sound work.  Have transferred this installation to 2 other computers
using fsarchiver with mostly positive results.

I would like to use the falkon browser but it depends on the qt5-webengine
package which is not available.  Any chance of adding this the the repos?

Thanks again.

More information about the Dev mailing list