[Dev] icu 59.1 broke calibre

nospam at curso.re nospam at curso.re
Mon May 8 19:06:54 GMT 2017


I have just tried to run calibre and it's failing because it can't find
libicui18n.so.58 (which is not available any more in Parabola)

The error is below

Traceback (most recent call last):
  File "/usr/bin/calibre", line 19, in <module>
    from calibre.gui_launch import calibre
  File "/usr/lib/calibre/calibre/__init__.py", line 22, in <module>
    from calibre.startup import winutil, winutilerror
  File "/usr/lib/calibre/calibre/startup.py", line 151, in <module>
    from calibre.utils.icu import title_case, lower as icu_lower, upper as icu_upper
  File "/usr/lib/calibre/calibre/utils/icu.py", line 28, in <module>
    raise RuntimeError('Failed to load icu with error: %s' % err)
RuntimeError: Failed to load icu with error: libicui18n.so.58: cannot open shared object file: No such file or directory
/usr/lib/calibre/calibre/ptempfile.py:29: RuntimeWarning: Parent module 'calibre' not found while handling absolute import
  import shutil

In fact, calibre is trying to load an shared object that depends on icu 58

 ldd /usr/lib/calibre/calibre/plugins/icu.so
        linux-vdso.so.1 (0x00007ffe66d88000)
        libpython2.7.so.1.0 => /usr/lib/libpython2.7.so.1.0 (0x00007f9ac1d32000)
        libicui18n.so.58 => not found
        libicuuc.so.58 => not found
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f9ac198e000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f9ac1770000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f9ac156c000)
        libutil.so.1 => /usr/lib/libutil.so.1 (0x00007f9ac1367000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f9ac1054000)
        /usr/lib64/ld-linux-x86-64.so.2 (0x000055a411a74000)

I tried to rebuild calibre from abslibre but makepkg fails because it
can't verify the package with gpg (even after pacman-key --refresh-keys):

==> Making package: calibre 2.83.0-2.parabola1 (Mon May  8 19:51:18 BST 2017)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found calibre-libre-2.83.0.tar.xz
  -> Found calibre-libre-2.83.0.tar.xz.sig
==> Validating source files with sha512sums...
    calibre-libre-2.83.0.tar.xz ... Passed
    calibre-libre-2.83.0.tar.xz.sig ... Skipped
==> Verifying source file signatures with gpg...
    calibre-libre-2.83.0.tar.xz ... FAILED (invalid public key 49F707A1CB366C580E625B3C456032D717A4CD9C)
==> ERROR: One or more PGP signatures could not be verified!

I am a bit out of options here and your help is much appreciated.


-- S.

More information about the Dev mailing list