[Dev] How can I enable SPIdev on Parabola ARM?

Josh Branning lovell.joshyyy at gmail.com
Fri Apr 28 14:03:29 GMT 2017

It doesn't say which kernel all of those options apply to. If it's the 
sunxi kernel, then you may be out of luck. If it's the mainline kernel, 
which it probably is [1], don't you just edit the defconfig for the 
kernel, find those options and set them, then recompile the kernel?

If I understand correctly, there is no need to modify a fex file, as 
mainline kernels use the device tree model instead.

Why they weren't enabled in the first place though is a question to ask.



On 28/04/17 00:48, Megver83 wrote:
> I'm sorry, but I think you didn't understand. I just want Parabola to
> detect the GPIO pins, which is located in /dev/spidev* (virtually). GPIO
> pins are peripherals.
> And the reason is that I want to flash Libreboot on a ThinkPad *with the
> BPi*, I do not want to flash Libreboot on the Pi (AFAIK no one has tried
> that).
> El 27/04/17 a las 20:14, Josh Branning escribió:
>> On 27/04/17 20:21, Megver83 wrote:
>>> Hi everyone, I want to flash libreboot with my Banana Pi M1, but I
>>> haven't found a way to enable the /dev/spidev* devices. I've tried
>>> enabling spidev and spi-sun4i modules, but nothing. In some forums, it
>>> tells me to edit the famous /boot/config.txt which is only available
>>> for the RPi.
>>> I've read http://linux-sunxi.org/SPIdev but I really do not know the
>>> difference between "y" and "m" in kernels (I know that "m" stands for
>>> "module"). If you can help me, I'd be very thankful.
>> IIRC y stands for "yes", assuming support is in the kernel, and y is to
>> enable that support. I think you are correct that m is for "module".
>> Have you tried UART connection?
>> Before arch linux arm supported the A10 olinuxino-lime, I got u-boot and
>> a kernel compiled with an arch linux rootfs, to put on an sdcard [1]. I
>> also did the same for an A13 tablet (although it had/needed proprietary
>> wifi drivers).
>> It was a long time ago, but I also had problems, so debugged using UART,
>> and can strongly recommend this for sunxi devices.
>> That said, I did not use libreboot, I used u-boot instead. Somebody had
>> already ported u-boot to those boards, so not much work was needed.
>> Sorry if I cannot be of any more help, I am by no means an expert,
>> Nowadays, I just install the arch linux arm image, and follow the
>> migration guide, which doesn't help much for debugging, but seems to work.
>> Josh
>> [1]
>> http://www.publicsite.org/J05HYYY/software_downloads/olinuxinolime-archlinux.tar.gz
>> _______________________________________________
>> Dev mailing list
>> Dev at lists.parabola.nu
>> https://lists.parabola.nu/mailman/listinfo/dev

More information about the Dev mailing list