[Dev] libretools 20160510 release announcement

André Silva emulatorman at riseup.net
Tue May 10 11:43:09 GMT 2016


On 05/10/2016 08:09 AM, André Silva wrote:
> On 05/10/2016 04:09 AM, André Silva wrote:
>> On 05/10/2016 02:34 AM, Luke Shumaker wrote:
>>> When creating an ARM chroot, or when creating an x86 chroot after
>>> creating an ARM chroot, there may be errors about package signing.
>>> Just delete the chroot, and try again; it should work.  I believe this
>>> hast to do with how we do package signing for imported packages, and
>>> not with libretools itself.
>>
>> I replicated it and the ARM chroot creating works after delete the
>> chroot and try again, however i have troubles to build packages using
>> "sudo libremakepkg -n my-armv7h-chroot" eg:
>>
>> ==> Starting to build the package...
>>  |  setarch: armv7h: Unrecognized architecture
> 
> I tried use coadde solution [0] and now it has been solved, however i
> have another different issue in the next step of the building, eg:
> 
> ==> Starting to build the package...
>  |  ==> Making package: linux-libre 4.5.3_gnu-1
>  |  ==> Checking runtime dependencies...
>  |  ==> Checking buildtime dependencies...
>  |  ==> Installing missing dependencies...
>  |  sudo: effective uid is not 0, is /usr/bin/sudo on a file system with
> the 'nosuid' option set or an NFS file system without root privileges?
>  |  ==> ERROR: 'pacman' failed to install missing dependencies.
> 
> [0]:https://projects.parabola.nu/packages/devtools-par.git/commit/?id=c3819bb4224622c6d10ab7a3511472f314e026ba

Some minutes ago, coadde pushed a modification for binfmt-qemu-static in
abslibre to add C flag to support suid (needed for sudo and others) [0],
i tested it and now it works!!! \o/

[0]:https://projects.parabola.nu/abslibre.git/commit/?id=a7ff5069dfad0df414403a1588bbaa186252ef12

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.parabola.nu/pipermail/dev/attachments/20160510/f712dcf1/attachment.sig>


More information about the Dev mailing list