[Dev] [RFC] Voting about package naming for packages modified from Arch

Luke Shumaker lukeshu at sbcglobal.net
Sun Aug 31 03:31:04 GMT 2014

At Sat, 30 Aug 2014 16:53:41 -0300,
André Silva wrote:
> On 08/29/2014 03:20 PM, Michał Masłowski wrote:
> > Luke Shumaker wrote:
> > >      e. Whe packaging a kernel module package (or other package
> > >         specific to a kernel version), name it
> > >         "${_pkgbase}${_kernelname}" and give it
> > >         pkgrel=${archrel}.parabola${parabolarel}.${_basekernel}"
> i support the pkgrel=${archver}.parabola${parabolarel} idea, because
> it means which it's being maintained by us, but it should be for all
> packages without exceptions.
> Add ${_basekernel} on kernel module packages is not ok because
> confuses the users and developers need to make special rules for
> each specific case.

sticking _basekernel into pkgrel means that

 1) The maintainer doesn't have to dick around with pkgrel when just
    bumping _basekernel.
 2) The package version reflects which kernel version the package was
    built for; otherwise the user would have to actually inspect the
    package to do this.

> Also, upstream releases on those packages are done due config
> modifications (eg: enable/disable a module or feature from config
> files), not only kernelbase upstream.
> In my opinion, we should have less rules and be more KISS.

Happy hacking,
~ Luke Shumaker

More information about the Dev mailing list