[Dev] [Packages (i686 and x86_64) - Bug #331] Broken texlive-bin-libre Dependency for libpng15

labs at parabola.nu labs at parabola.nu
Sat May 11 17:19:57 GMT 2013



Issue #331 has been updated by 5gon12eder.


<pre>
$ scanelf -plRqN libpng15.so.15 | cut --delimiter=' ' -f3- | xargs pacman -Qo
/usr/lib/gstreamer-0.10/libgstcog.so is owned by gstreamer0.10-bad-libre-plugins 0.10.23-4
/usr/lib/libcupsfilters.so.1.0.0 is owned by cups-filters-libre 1.0.34-3
/usr/bin/dvipdfmx is owned by texlive-bin-libre 2012.0-11
/usr/bin/pdftex is owned by texlive-bin-libre 2012.0-11
/usr/bin/xdvipdfmx is owned by texlive-bin-libre 2012.0-11
/usr/bin/luatex is owned by texlive-bin-libre 2012.0-11
/usr/bin/xetex is owned by texlive-bin-libre 2012.0-11
</pre>

I have removed _libpng15_ again, in case this should matter, to mimic the state of the system immediately after the update when the problem first occurred.  All listed packages seem to be up to date. Reinstalling them (again) didn't change anything.
----------------------------------------
Bug #331: Broken texlive-bin-libre Dependency for libpng15
https://labs.parabola.nu/issues/331

Author: 5gon12eder
Status: info needed
Priority: broken
Assignee: 
Category: 
Target version: 


After updating my system today, the _TeX Live_ programs (_pdflatex_, _xelatex_, …) fail to process PNG images due to the (now?) missing library @libpng15.so.15 at .

<pre>
$ ldd `which xelatex`
	linux-vdso.so.1 (0x00007fff9d3fe000)
	libpoppler.so.36 => /usr/lib/libpoppler.so.36 (0x00007fc76f2f1000)
	libpng15.so.15 => not found
	libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007fc76f0b5000)
	libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fc76ee16000)
	libz.so.1 => /usr/lib/libz.so.1 (0x00007fc76ec00000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fc76e8fc000)
	libm.so.6 => /usr/lib/libm.so.6 (0x00007fc76e5fe000)
	libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fc76e3e8000)
	libc.so.6 => /usr/lib/libc.so.6 (0x00007fc76e03b000)
	libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fc76de1f000)
	liblcms2.so.2 => /usr/lib/liblcms2.so.2 (0x00007fc76dbcb000)
	libtiff.so.5 => /usr/lib/libtiff.so.5 (0x00007fc76d958000)
	libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007fc76d707000)
	libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fc76d4d2000)
	libopenjpeg.so.1 => /usr/lib/libopenjpeg.so.1 (0x00007fc76d2a9000)
	libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fc76d07f000)
	libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fc76ce6f000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc76f74d000)
	liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007fc76cc4c000)
</pre>

I see that _texlive-bin-libre_ was last built on May 8, while _libpng_ was last built on May 7, so I suspect the rebuilt might be related to the _libpng_ update and the current version thus be up-to-date.  I'm somewhat confused why _xelatex_ links against both @libpng15.so.15@ and @libpng16.so.16 at .  Is this normal?

After some reading, I could (for now, I really needed _TeX_ to work again) solve the issue by downloading, building and installing _libpng15_ from _Arch_ AUR alongside with _libpng16_ but I don't think this is the correct way to solve this issue.



--
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://labs.parabola.nu/my/account



More information about the Dev mailing list