[Dev] [Libretools - Bug #188] (fixed) [libremkchroot] doesn't always umount when exiting with error

labs at parabola.nu labs at parabola.nu
Fri May 3 01:15:09 GMT 2013

Issue #188 has been updated by lukeshu.

Status changed from open to fixed
% Done changed from 50 to 100

With the version now in git, instead of a literal bind mount, it used `systemd-nspawn --bind`, which means that they won't exist once the process exits. Done.
Bug #188: [libremkchroot] doesn't always umount when exiting with error

Author: lluvia
Status: fixed
Priority: bug
Target version: don't break and confuse parabolers

For example, I failed my previous command for libremkchroot, and I tried it a second time with the correct arguments, but it wanted to overwrite the mounted system, reporting errors.

Also, I didn't understand what was happening and I tried to remove the jail directory, without checking that my system was mounted in that directory!

It would be a good and simple behavour to unmount if reporting error.

You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://labs.parabola.nu/my/account

More information about the Dev mailing list