[Dev] [Libretools - Bug #188] [libremkchroot] doesn't always umount when exiting with error

labs at parabola.nu labs at parabola.nu
Wed Apr 24 14:18:23 GMT 2013



Issue #188 has been updated by lukeshu.


Once I merge changes from upstream devtools, this will be fixed with certainty; it will be handled by nspawn.
----------------------------------------
Bug #188: [libremkchroot] doesn't always umount when exiting with error
https://labs.parabola.nu/issues/188

Author: lluvia
Status: open
Priority: bug
Assignee: 
Category: 
Target version: don't break and confuse parabolers


For example, I failed my previous command for libremkchroot, and I tried it a second time with the correct arguments, but it wanted to overwrite the mounted system, reporting errors.

Also, I didn't understand what was happening and I tried to remove the jail directory, without checking that my system was mounted in that directory!

It would be a good and simple behavour to unmount if reporting error.



--
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://labs.parabola.nu/my/account


More information about the Dev mailing list