[Dev] [Gnewsense-dev] missing grub-mkfont (grub 2.00) in Yeelong

s.boutayeb at free.fr s.boutayeb at free.fr
Mon Nov 12 23:22:02 GMT 2012

Quoting Sam Geeraerts <samgee at elmundolibre.be>:

> Samy Boutayeb wrote:
> > Thanks, I installed grub-common. Now, grub-mkimage is in /usr/bin/
> >
> > Then, I tried to configure grub-2.00 again. Unfortunately, it ends with
> > "error: loongson port needs grub-mkfont"
> >
> > Same result with:
> > configure --enable-grub-mkfont=no
> I tried it myself now and configure just works for me. But the error
> message concerns the configure flag, not a build dependency. So try with
> --enable-grub-mkfont=yes.
Thanks Sam

The initial attempt to configure grub-2.00 (from http://ftp.gnu.org/gnu/grub/ )
failed, either with --enable-grub-mkfont=no or with --enable-grub-mkfont=yes

Finally, I managed to install grub-yeeloong-bin
(grub-yeeloong_2.00-7_mipsel.deb, from debian/testing) on a Yeeloong with
GnewSense/parkes (kernel 3.6.6-gnu), with following workaround.

apt-get install grub-yeeloong
grub-install /dev/sda1 --directory=/usr/lib/grub/mipsel-loongson/

The issue with the missing "--target" or "--directory" parameter is described in

and is caused by a bug described in

So, after rebooting the Yeeloong, the grub screen displays as expected.

More information about the Dev mailing list