[Assist] How can I downgrade GCC?

hironori.ueno hironori.ueno at protonmail.com
Tue Mar 1 07:11:11 GMT 2022


thank you.
I understand that it has already been registered as an issue.

------- Original Message -------

On Tuesday, March 1st, 2022 at 3:43 PM, Andreas Grapentin andreas at grapentin.org wrote:

> fwiw, we have an issue that tracks this problem here:
>
> https://labs.parabola.nu/issues/3190
>
> Best,
>
> Andreas
>
> On Tue, Mar 01, 2022 at 04:30:10AM +0000, hironori.ueno wrote:
>
>> Thank you Denis.
>>
>> I am using the following versions of the kernel and architecture.
>>
>> $ uname -rm
>>
>> 5.15.12-gnu-1 x86_64
>>
>> I also knew that I needed to get the developers to build
>>
>> the kernel with a newer version of GCC.
>>
>> However, since it is a rolling release method, I thought that
>>
>> the problem was that I updated the GCC package without
>>
>> checking it, so I tried to downgrade(and it didn't work)
>>
>> Should I contact the kernel package maintainer in such cases?
>>
>> ------- Original Message -------
>>
>> On Tuesday, March 1st, 2022 at 7:20 AM, Denis 'GNUtoo' Carikli GNUtoo at cyberdimension.org wrote:
>>
>>> On Mon, 28 Feb 2022 13:36:01 +0000
>>>
>>> "hironori.ueno" hironori.ueno at protonmail.com wrote:
>>>
>>>> Hi,
>>>
>>> Hi,
>>>
>>>> I have a problem and please let me know if there is a solution.
>>>>
>>>> I tried to build a module for dkms and got the following warning:
>>>>
>>>> ----------------------------
>>>>
>>>> warning: the compiler differs from the one used to build the kernel
>>>>
>>>> The kernel was built by: gcc (GCC) 11.1.0
>>>>
>>>> You are using: gcc (GCC) 11.2.0
>>>>
>>>> ----------------------------
>>>
>>> This is probably because we use GCC plugins for building the kernel:
>>>
>>>> $ grep CONFIG_GCC_PLUGINS abslibre/libre/linux-libre-/config.
>>>>
>>>> abslibre/libre/linux-libre-64/config.aarch64:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-64/config.armv7h:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-64/config.i686:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-64/config.x86_64:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-lts/config.armv7h:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-lts/config.i686:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-lts/config.x86_64:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-pck/config.armv7h:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-pck/config.i686:CONFIG_GCC_PLUGINS=y
>>>>
>>>> abslibre/libre/linux-libre-pck/config.x86_64:CONFIG_GCC_PLUGINS=y
>>>
>>> The solution is probably to have Parabola developers rebuild the kernels
>>>
>>> with newer GCCs here.
>>>
>>> What kernel and Parabola version (i686, armv7h, x86_64) do you use?
>>>
>>> Denis.
>
>> _______________________________________________
>>
>> Assist mailing list
>>
>> Assist at lists.parabola.nu
>>
>> https://lists.parabola.nu/mailman/listinfo/assist
>
> --
>
> ------------------------------------------------------------------------------
>
> my GPG Public Key: https://files.grapentin.org/.gpg/public.key
>
> ------------------------------------------------------------------------------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20220301/31d2491d/attachment.htm>


More information about the Assist mailing list