[Assist] [ASK] Installation Issue with "Error Retrieving Keys" Messages

Ade Malsasa Akbar malsasa at disroot.org
Sun Nov 21 08:52:42 GMT 2021

Greetings and respects to Parabola Community,

Hello, I am Ade from Indonesia. I tried to install Parabola LXDE in a
virtual machine but failed after multiple attempts for a week with the
same error messages. I explain below.

- My specification: a QEMU virtual machine with 64-bit CPU and 2GB
memory and has been tested successful installing Guix GNOME Desktop.

- My ISO image: parabola-openrc-lxde-2021.08.11-dual.iso

- Expected behavior: installation process works normally

- Actual behavior: installation process took an unusually long time by
the key retrieval errors without continuing to the next step

- Chronology when using the original script:

    1. I ran the virtual machine with Parabola LXDE iso and networking

    2. I landed on the LXDE desktop.

    3. I changed the DNS into ones I tested to be working in its

    4. I ran the Parabola Installer on the wallpaper, or, I ran the
    install.sh directly.

    5. I saw the initial configuration like pacman -Syy process and it
    worked normally.

    6. I saw the keys retrieval process and many keys threw identical
    errors in a very long time.

    7. Step number 6 took about one to two hours and it seemed to be
    never ending then I terminated it.

    8. I repeat the process since the Step number 1 multiple times
    without a success for one week now.

- Error messages:

Multiple instances of "Error retrieving [...] via WKD: connection timed
out" where [...] is email address of the owner of each key.

Multiple instances of "Error reading key: Connection refused".

Multiple instances of red colored "ERROR: could not update key [...]"
where [...] is an alphanumeric code.

- Suspicion:

Lately in 2021, but I saw several other people at both Arch and Parabola
forums to report similar errors where I concluded this was related to
European's GDPR case where a public keyserver (or something related to
it) being shutdown. Perhaps this is the cause of my issue.

- Notes:

I have read and practiced both https://wiki.parabola.nu/Parabola_Keyring
and https://wiki.parabola.nu/Pacman_troubleshooting command by command,
multiple times for days, which both are often referenced to face such
issues I mentioned above and it still failed.

- Question:

How to solve this issue?

Thank you very much and please forgive me of my mistakes for I am a new
member here.

Sincerely yours,

Ade Malsasa Akbar

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20211121/10120a97/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_0x60077419C5CD7BD7.asc
Type: application/pgp-keys
Size: 2450 bytes
Desc: not available
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20211121/10120a97/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 665 bytes
Desc: OpenPGP digital signature
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20211121/10120a97/attachment-0001.sig>

More information about the Assist mailing list