[Assist] Boot process halts before getty is reached

Leon Plickat leonhenrik.plickat at stud.uni-goettingen.de
Tue Nov 5 15:56:39 GMT 2019

On Di 05.11.2019, 11:13, Freemor wrote:
> Change vga=ask to vga=773

That did not work, the screen still blanks, with the slight difference that
there are now corrupted and warped artifacts of the previous boot messages at
the bottom.

> is so that computer may not actually be freezing. Just not bothering to
> display anything once it tries to switch to the wonky FB.

I tried to do stuff blind (playing a sound file) but that did not work. So maybe
keyboard events are not processed as well?

> You can try adding  lines to your .bashrc to start an X11 session right away
> which would switch away from the wonky FB to a regular graphics mode. And that
> might get your display back.

I already have that. In fact, when this error first came up, I though that it,
in combination with agetty auto-login, was the culprit.

> Another option to help debug this is to enable opensshd so you can try ssh'ing
> to the machine once it's booted (assuming it is booting but not displaying) and
> check things by ssh'ing in from another machine

I am in a large network I have no control over, so I'd need the IP for SSH,
which I can not get when the screen is not working correctly.

> You may also want to read through:
> https://wiki.archlinux.org/index.php/Intel
> Paying attention to the sections about KMS, early KMS , and adding intel
> modules to your initramfs. That last part in under the heading "Blank screen
> during boot, when "Loading modules" in the troubleshooting section

I quickly skimmed over that (I'll read it thoroughly later this day when I have
more time) and found a workaround. I disabled kernel mode setting and now the
computer reliably boots to getty. It is not a very good workaround, as Wayland
needs KMS, but it will suffice for a few days.

Also, now that I can log in again, I noticed that there are more problems since
that update. First, the TTY is now regularly plastered with log messages.
Secondly, both NM and 'rfkill' fail to recognize any network devices roughly 9
out of 10 boots. And last but not least, shutdown does not work. Usually it
complains about 'system-udevd' not stopping, the exact message being:

    systemd-shutdown[1]: Waiting for process: systemd-udevd, systemd-udevd, systemd-udevd, systemd-udevd, systemd-udevd, systemd-udevd

Other times I get that weird KVM / 'oldroot' message again and once even a
kernel panic:

    Kernel panic - not syncing: Timeout: Not all CPUs entered broadcast exception handler

Before that update, my installation was perfectly stable without any such
issues. The hardware is also fine, I booted the laptop with a Debian drive and
everything worked as expected.

So maybe the kernel is bad?

Friendly greetings and thanks for the help,
Leon Plickat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20191105/0b7ea113/attachment.sig>

More information about the Assist mailing list