[Assist] sudo and pacman broken...

jc_gargma jc_gargma at iserlohn-fortress.net
Mon May 1 16:56:17 BST 2017

> and this won't work since there conflicting files: 'libcrypto.so.1.0.0'
> and 'libssl.so.1.0.0'
I ran into this myself the other day.

I had to boot from a Parabola LiveDVD I had laying around to repair it.
If you don't have one already made, you may need to find someone to burn you a 
copy either to USB or DVD depending on your hardware.
For a LiveUSB, it's a quick
sudo dd if=/location/of/Parabola/ISO of=/location/of/USB/Drive
(Don't flash to a USB partition. Ex. Use /dev/sdb not /dev/sdb1 where /dev/sdb 
is the mount point of the USB drive.)

Once you have a LiveDVD/USB:
Boot into the LiveDVD/USB
mount /your/root/drive/location /mnt
mount /your/home/drive/location /mnt/home
pacstrap /mnt openssl-1.0
arch-chroot /mnt
pacman -Syyu
umount /mnt/home
umount /mnt

This should repair it.

Other issues I ran into:
pacman was unable to pull packages from https repos, as sync via https would 
cause pacman to segfault.
I had to set the topmost repos in /etc/pacman/mirrorlist to http
After a full
sudo rm /var/lib/pacman/db.lock
sudo pacman -Scc
sudo pacman -Syyu
that was fixed.

Originally, I tried a full
pacstrap /mnt base openssl-1.0
which also necessitated repairing the initramfs using
arch-chroot /mnt
mkinitcpio -p linux-libre

Until everything is rebuilt using openssl 1.1, the openssl-1.0 compatibility 
package will likely be required.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20170501/25cb43af/attachment.bin>

More information about the Assist mailing list