[Assist] Snapper and OpenRC

Omar Polo omar.polo at europecom.net
Sun Jun 4 22:02:24 BST 2017


Hi,

two days ago I reinstalled parabola on my laptop and I've decided to use
openrc as init system.

So far everything went well, but now I've noticed that snapper does not
work as expected.

Snapper is a tool to create and manage snapshots of BTRFS and LVM
partitions.

The problem is that when I run any command that involves `snapper(8)` I
get
```
Operation not succeeded (org.freedesktop.DBus.Error.Spawn.ExecFailed).
```

BUT, if I start `snapperd` in some terminal, `snapper` suddenly start
working. Unfortunately `snapperd` stops itself after a short period of
time.

Digging in the source code of snapper, I've understood that `snapperd`
relies on dbus for its activation. [^1]

Given this, how can I solve this problem? Manually running `snapperd`
could temporary fix this problem, but isn't something I'd like to do on
a daily basis.

I've tried to write an init.d script that starts `snapperd`, but
`snapperd` quit itself after inactivity.

Obviously all mentioned command were executed as root

* * *

[^1]: The snapper' systemd unit file is:
```
# DBus service activation config
[D-BUS Service]
Name=org.opensuse.Snapper
Exec=/usr/sbin/snapperd
User=root
```

-- 
No computers were harmed in the making of this email, only free (as in freedom)
software was used
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: not available
URL: <https://lists.parabola.nu/pipermail/assist/attachments/20170604/fcb0e4bf/attachment.bin>


More information about the Assist mailing list