[Assist] OpenRC LXDE iso = no joy

edgar at openmail.cc edgar at openmail.cc
Mon Dec 25 07:30:03 GMT 2017


Hello,

I want to report that I could not get the OpenRC LXDE iso to work on my 
machine. I tried with

- parabola-openrc-lxde-2017.10.26-dual
- parabola-openrc-lxde-2017.11.05-dual

I made some notes about the second one:

START =====
- could not install base-openrc, dialog was fine # shouldn't it be a 
single line?
   - pacstrap /mnt pacman
   - arch-chroot /mnt
     pacman -Sy parabola-keyring archlinux-keyring --noconfirm
     pacman-key --populate parabola archlinux
     pacman-key --refresh-keys
     pacman -S base-openrc
     :: libeudev and libudev are in conflict (libudev.so). Remove 
libudev? [y/N] y
     :: util-linux-nosystemd and util-linux are in conflict. Remove 
util-linux? [y/N] y
     :: eudev-systemd and systemd are in conflict (systemd-tools). Remove 
systemd? [y/N] y
     :: libeudev-systemd and libsystemd are in conflict. Remove 
libsystemd? [y/N] y
     :: libeudev-systemd and libsystemd-standalone are in conflict. 
Remove libsystemd-standalone? [y/N] y
     - it tried to install libdbi 0.9.0-2, which was corrupted
       error: libdbi: key "Thorsten Töpper <atsutane at freethoughts.de>" is 
disabled
       :: File /var/cache/pacman/pkg/libdbi-0.9.0-2-x86_64.pkg.tar.xz is 
corrupted (invalid or corrupted package (PGP signature)).
       - downloaded 0.9.0-3 from 
https://www.parabola.nu/packages/?q=libdbi # on host
         copied to /mnt/var/cache/pacman/pkg # on host
         pacman -U /var/cache/pacman/pkg/libdbi-0.9.0-3-x86_64.pkg.tar.xz 
# back in chroot
         pacman -S base-openrc
- could not install polkit-elogind
   - pacman -r /mnt polkit-elogind # on host
     :: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? 
[y/N] y
- retry install desktop, no joy
- copy list of packages to terminal as an array
   pacman -S -r /mnt ${packages[@]} --needed
   warning: removing 'lxdm' from target list because it conflicts with 
'lxdm-consolekit'
   :: polkit-consolekit and polkit-elogind are in conflict (polkit). 
Remove polkit-elogind? [y/N] N
   - OpenRC seems to need polkit-consolekit; check this: 
https://forum.manjaro.org/t/fix-dependency-conflict-in-lxde-package-group/11642/10
     This may be useful? (did not add the mirrors) 
https://systemd-free.org/migrate.php
     The problem is that lxde tries to install lxdm-consolekit, and 
everything else has elogind, so copy the packages in lxde
     - install groups' packages manually # inside arch-chroot
       pacman -S gpicview lxappearance lxappearance-obconf lxde-common 
lxde-icon-theme lxdm lxhotkey lxinput lxlauncher lxmusic lxpanel lxrandr 
lxsession lxtask lxterminal openbox pcmanfm
       comment lxde in the package list of install.sh
- retry install desktop, no joy
   arch-chroot /mnt
   pacman -R networkmanager consolekit-openrc consolekit 
networkmanager-openrc
   pacman -S networkmanager-elogind
- retry install polkig-elogind # on host
   pacman -r /mnt -S elogind-openrc polkit-elogind
- retry install desktop, joy! (with some messages)
   ( 1/13) Updating linux-libre initcpios
   ==> ERROR: /proc must be mounted!
   error: command failed to execute correctly

   ( 7/13) Reloading GVFS config...
   killall: /proc lacks process entries (not mounted ?)

====== END

After this, rebooted into a screen with an error message. After hitting 
enter, a terminal login prompt appeared.

I would also suggest to create a temporary mount folder based on UUID 
for the install.sh script (instead of always mounting on /mnt). 
Something like this may help:
myuuid=$(lsblk -no UUID /dev/"$drive""$part" ||
                           exit)

I hope that it helps someone. I can't afford to spend more time on this. 
Thank you very much for your hard work.

-------------------------------------------------

ONLY AT VFEmail! - Use our Metadata Mitigator to keep your email out of the NSA's hands!
$24.95 ONETIME Lifetime accounts with Privacy Features!  
15GB disk! No bandwidth quotas!
Commercial and Bulk Mail Options!  


More information about the Assist mailing list