[Assist] signature problems with latest updates...help/guidance please.

Ben uaqben at openmailbox.org
Thu Apr 27 23:00:03 BST 2017

Hi All,

tl;dr - I saw boatload of updates on 24th April; checked the public Dev
mailing list here; saw disarray, with some hackers leaving, others
joining.. I decided to give myself some time to read through those
emails, and decide what to do

So, I'm a recent parabola user; it's been 3 months appx.

Tuesday's update surprized me by its size; hence my checking mailing
list in case

fyi: I do run pacman -Syu, at every boot up before getting to work

Anyways, I wait until this evening, taking time to read through some of
the recent threads.. And now, this evening, after long day, I decided
that I could & should go ahead with updating.

1. linux-libre was causing issues, due to megver83 signing issue.

2. I remember mailing list thread, except that being tired, I ran
`pacman -S parabola-keyring` first, and then `pacman-key --refresh-keys`

    + pacman -Syu fails

3. I check mailing list, and see on homepage parabola.nu, it should have
been the other way around...

4. I remember libreboot install doc for parabola mentionning a way to
resolve issues with signatures

   + pacman-key –populate parabola
   + pacman-key –refresh-keys
   + pacman -Sy parabola-keyring

5. sort of looks like progress & regression; linux-libre package is no
longer complained about; but `your-freedom`
and `pacman` itself get complaints...

6. that's when I should have stopped and reached out for help

7. but for some stupid (educational..? {I will be remembering this})
reason, I decide I could join the mailing list tomorrow, and in the
meantime quickly update the other packages.. I test with `pacman -S
git`, works fine, and then..

8. I run a first biggish bunch:

    pacman -S `adwaita-icon-theme apache apr apr-util at-spi2-atk
at-spi2-core atk atkmm baobab ca-certificates-mozilla cairomm cheese
clutter clutter-gst cogl colord coreutils curl dbus dconf dconf-editor
ekiga empathy eog evince evolution-data-server exempi folks freerdp
fuse-common gcr gdk-pixbuf2 gdm gedit gedit-plugins geoclue2
geocode-glib gjs glib-networking glib2 glibmm gmime`

9. updates fine; but when doing next bunch, `pacman -S` fails (At least
it the damaged stopped there), it errors:

    `pacman: error while loading shared libraries: libssl.so.1.1: cannot
open shared object file: No such file or directory`

Any kind soul(s) can help me? Or point me in right direction..

I saw on Arch forum, an old 2010 post. It mentions symlinking libssl, so
as to temporarily get pacman back up & running, and thus be able to run
`pacman -Syu`... but I'm tired, need sleep, and I know I have yet to
resolve the darn GPG signature issue...



More information about the Assist mailing list