[Assist] Arduino - Trouble with libncurses

Scott Adams sradms0 at openmailbox.org
Sat Jun 25 06:05:24 BST 2016

No problem for the double reply, Sergei.

I was not logged in to my e-mail, while troubleshooting still, and came 
up with a different solution.

I should have tried this in the first place.

I'm running Trisquel GNU/Linux on my x200, and arduino runs fine, so I 
figured that ilbncurses.so.5 is there somewhere.

I then located it, copied it, and then placed the copy in my /usr/lib on 
my Parabola GNU/Linux pc.

Uploaded to my Arduino board successfully!

On 06/25/16 00:15, Sergei Akhmatdinov wrote:
>> Wait I fixed it.
>> I created a directory, but now the issue is
>> ln: failed to create symbolic link
>> '/home/scott/arduino_build/pkg/arduino/usr/share/arduino/hardware/tools/avr/lib/libtinfo.so.5':
>> No such file or directory
>> ==> ERROR: A failure occurred in package().
>>       Aborting..
> [[[ My mailing client only replied to Scott and not the mailing list for
> whatever reason, so I apologize to Scott for two messages. ]]]
> I'd say the core PKGBUILD is faulty.
> I'd try the one from AUR, I don't see it pulling any non-free depends.
> https://aur.archlinux.org/packages/arduino/
> Install libxtst too, the comments say it may be a missing depend.
> Cheers,

More information about the Assist mailing list