[Assist] Cannot access website with Iceweasel

Florian Pelz pelzflorian at pelzflorian.de
Wed Nov 18 18:03:48 GMT 2015

On 11/18/2015 06:52 PM, Francesco Turco wrote:
> I'm using Iceweasel 42.0 and I cannot access my utility website. If I go
> to http://www.eon-energia.com/it/servizi-online/servizi-online.html and
> click on the red button "Entra" I get redirected to
> https://eon-eservice.eon-energia.com/PublicPages/Login.aspx but then it
> fails with the following error message:
> -----
> Secure Connection Failed
> The connection to eon-eservice.eon-energia.com was interrupted while the
> page was loading.
>     The page you are trying to view cannot be shown because the
>     authenticity of the received data could not be verified.
>     Please contact the website owners to inform them of this problem.
> -----
> I tried to contact the customer service of the website but they seem to
> be clueless. I tried creating a fresh new Iceweasel profile to no avail.
> With the Web/Epiphany web browser I *can* access it, instead. So it
> seems a problem specific to Iceweasel.
> Any ideas? Thanks.

I can reproduce in IceCat. IceCat is more strict with SSL than Firefox
currently is.

You should go to ssllabs.com and test their server at domain
eon-eservice.eon-energia.com . It shows some really big problems with
their server.

More information about the Assist mailing list