[Assist] Cannot access website with Iceweasel

Francesco Turco fturco at fastmail.fm
Wed Nov 18 17:52:57 GMT 2015

I'm using Iceweasel 42.0 and I cannot access my utility website. If I go
to http://www.eon-energia.com/it/servizi-online/servizi-online.html and
click on the red button "Entra" I get redirected to
https://eon-eservice.eon-energia.com/PublicPages/Login.aspx but then it
fails with the following error message:


Secure Connection Failed

The connection to eon-eservice.eon-energia.com was interrupted while the
page was loading.

    The page you are trying to view cannot be shown because the
    authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.


I tried to contact the customer service of the website but they seem to
be clueless. I tried creating a fresh new Iceweasel profile to no avail.
With the Web/Epiphany web browser I *can* access it, instead. So it
seems a problem specific to Iceweasel.

Any ideas? Thanks.

More information about the Assist mailing list