[Assist] [Linux-Libre 3.9.7-gnu] mkinitcpio not adding modules to image

Kuba Kukielka kzer-za at cryptolab.net
Sat Nov 22 16:09:49 GMT 2014


I have been having problem with my graphics card (I have posted about this on this list already 
https://lists.parabola.nu/pipermail/assist/2014-November/000327.html ) and I wanted to install and
older version of the linux-libre kernel. I looked at some other free systems (GNewSense, Triquel and
the Parabola graphical image) and I took the kernel versions of the ones that worked using uname -r.

I tried to compile the linux-libre kernel using these commands;

(I first changed directory after extracting the archive)

	make O=/home/kzer-za/build/kernel menuconfig
	make O=/home/kzer-za/build/kernel
	make O=/home/kzer-za/build/kernel modules_install install

(I used these commands when I was logged in as root)

Then I copied the bzImage and pasted it root and renamed it as "vmlinuz-linux-libre".
After that I ran;

	mkinitcpio -k 3.9.7-gnu -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-libre.img

But running that gave me;

==> Starting build: 3.9.7-gnu
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> WARNING: No modules were added to the image. This is probably not what you want.
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-libre.img
==> Image generation successful

I tried rebooting but then I got no keyboard input because no modules were loaded. From a live pendrive,
I installed the linux-libre package (which is incompatible with my graphics card but works) and reasearched
on the internet but nothing helped.


Kuba Kukielka <kzer-za at cryptolab.net>

More information about the Assist mailing list