[Assist] Problem with installing Parabola on Yeeloong

YAMAMOTO Kentaro ykentaro at acm.org
Thu Jun 6 08:51:33 GMT 2013

Dear Szymon,

Thank you for your help.

At Thu, 6 Jun 2013 08:58:21 +0200,
Szymon Olewniczak wrote:
> > 
> > I installed the MIPS port of Parabola on my Yeeloong 8089B, with
> > limited success.
> > 
> > I booted from a USB stick and followed the instructions on the wiki,
> > except that I run pacman -Su and pacman -Sc before installing packages
> > because pacman complained that some packages were without signature.
> > (I could not install iceweasel-libre due to an error in signature,
> > though.)  Along the way I had partitioned the HDD into one for / and
> > one for swap and extracted the tar ball in the former.  Then I
> > installed xorg.conf from the wiki in /etc/X11.
> I really recomend not to use icecat on this machine - it's to slow.
> The best solution would be netsurf. It has its own rendering engine and
> it's really fast and dealing with web pages much better than dillo.

I installed it via pacman, but it fails to load libpng shared object,

netsurf: error while loading shared libraries: libpng15.so.15: cannot
open shared object file: No such file or directory

> > The problem is that gdm does not run after reboot.  I could not find
> > any logs regarding gdm and X under /var/log.  Since systemctl
> > complains that it could not connect via DBus, I doubt systemd is
> > running properly.
> Do you really need gdm? This Yeeloong machines are not the most powerful
> ones so I think that gdm is unnessesery. Simple shell login and startx
> isn't enough for you? But anyway you must install DBus to have systemd
> working properly(dbus package in parabola repo). Then try to add gdm, as
> root:
> systemctl enable gdm
> If it doesn't report any error but X won't start, try to run in
> terminall:
> xinit /usr/bin/gdm -- :0 
> and tell me what do you get.

I gave up using gdm and run startxfce4.  X starts up and seemingly
works fine, except that I get corrupted screen if you move windows.
The problem is no matter how many times I reinstall DBus it does not
work at all.  I cannot use systemctl, nm-applet, or many other useful
programs.  For example, systemctl says

Failed to get D-Bus connection: No connection to service manager.

I noticed that every time I run pacman it warns me saying

waring: config file /etc/pacman.conf, line 19: diective 'SyncFirst' in
section 'options' not recognized.

I have not edited the corresponding section of the config file.

> Regards,
> Szymon
> _______________________________________________


More information about the Assist mailing list